GMOD stuttering a lot even with high fps

Messages
862
Reaction score
927
Points
565
Location
Helsinki, Southern Finland, Finland
I rejoined the server a week ago and started noticing I get these stutters from around 80-100 fps to as low as 20 for a few seconds. It really affects my gameplay and was wondering what could be the problem.

My specs are:

NVIDIA Geforce RTX 2060
AMD Ryzen 5 2600 3.8Ghz
Kingston 16GB DDR4 ram overclocked to 2900MHz
SSD for games


0:06
and
0:28 you can see a few big stutters


Another spike when the server was full.

Things I've tried with no avail:
Unparked cpu cores,
tried different cfg's
fullscreen borderless
 
Messages
2,060
Reaction score
2,554
Points
580
Location
Scotland
Messages
4,699
Reaction score
13,775
Points
615
Location
North Rhine-Westphalia, Germany
Hi, since you have a Ryzen I recommend updating your BIOS first and then the Chipset. You have to re-install the chipset drivers everytime you update your BIOS so it might be good to do that.

Other than that you could do some BIOS adjustments e.g. enable Quiet & Cool, not sure if your CPU is thermal throttling so clean it up a bit. XMP should hopefully be enabled as you've stated so double check it and see if your RAM is installed correctly for Dual Channel mode. I suggest you use 1usmus' Ryzen power plan for Zen 2, since you have a Zen+ you can use the Universal power plan it comes with and also use these BIOS changes that are listed on this site https://www.techpowerup.com/review/1usmus-custom-power-plan-for-ryzen-3000-zen-2-processors/

Those stutters are at this point normal for Garry's Mod, I didn't have them with 64-Bit but that one seems to be broken atm. If you ever get stutters when running someone over or killing them its probably just the auto screengrabber (lol) fucking up, that's normal too. All you can do at this point is remove all unnecessarry addons and use some launch options and/or use my .cfg https://perpheads.com/threads/updated-performance-guide-cfg-inside.39046/
Code:
-high -console -threads 6 -nosteamcontroller -nojoy -noff -softparticlesdefaultoff -reuse -noipx -nohltv -nocrashdialog -noforcemaccel -noforcemparms -noforcemspd
put in +exec autoexec.cfg if you're using a .cfg, -threads is already modified to have your 6 physical cores
 
Messages
862
Reaction score
927
Points
565
Location
Helsinki, Southern Finland, Finland
I've updated my bios when I was oc'ing my ram without ever updating my chipset. Also XMP wasnt working for me since my ram was absolute garbage so I went ahead and did OC'd it myself.
 
View previous replies…
Messages
3,302
Reaction score
3,981
Points
580
Location
Fortniteburger.net
Wait, this isnt how PERP looks for everyone?!?!?!?!?!

I found out setting all my graphics settings to the lowest could have been a major issue with my FPS. I set them all to the settings my geforce reccommended and my game is still smooth albeit stutters.
 
Top